> I've been using
> mvn versions:display-plugin-updates
> to show which plugins don't have versions specified.
> [versions is a very useful Maven plugin]
Looks very useful indeed.
> This shows that the Bundle plugin 2.0.0 exists - we are using 1.4.3.
> Now Bundle 2.0.0 requires Java 1.5, so I'm a bit wary about updating
> the version, as in theory one can build http core using Java 1.4. In
> practise, developers use 1.5+, so maybe this is not an issue, so would
> it be OK to update the version?
maven-bundle-plugin has a regression causing compatibility issues with
the assembly plugin. For details see this bug report